1. rancher2.1.x升级到2.2.x,无法查看/编辑yaml文件

此问题将在 v2.2.4 修复

image-20190430094043207

解决方法:

  • 架构为使用外部七层负载均衡器代理rancher ha

检查外部负载均衡器的配置,如果有http2的参数,把http2取消。比如nginx的配置:image-20190430094333165

  • 架构为使用内部ingress 七层代理Rancher HA

    1. 进入local集群,切换到系统项目\资源\配置映射页面,找到并编辑nginx-configurationimage-20190430094846660
    2. 添加use-http2=false禁止http2image-20190430094945817

2. 升级rancher后出现unable to handle the request

image-20190529230049960

rancher v2.0.x 、v2.1.x与v2.2.x之间证书存储方式有变化,出现以上问题因为存储方式发生变化后rancher无法连接到业务集群。